Scheduler Update and ATI cards

Message boards : News : Scheduler Update and ATI cards

To post messages, you must log in.

1 · 2 · 3 · Next

AuthorMessage
Thomas Koch
Project administrator
Project developer
Project scientist

Send message
Joined: 17 Feb 12
Posts: 436
Credit: 37,847
RAC: 0
Message 7591 - Posted: 9 Jan 2013, 10:37:51 UTC

We have just upgraded our server software with a small change to the memory allocation for ATI cards.
We don't expect problems, but if you are using an old client version and have trouble getting GPU tasks, please reply here.
ID: 7591 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Mad_Max

Send message
Joined: 24 Jan 12
Posts: 27
Credit: 656,410,733
RAC: 0
Message 7594 - Posted: 9 Jan 2013, 14:24:14 UTC - in response to Message 7591.  
Last modified: 9 Jan 2013, 14:24:46 UTC

Peaple who use app_info.xml on ATI cards need to update configuration?
Or it only change settings in WUs generated by server but exactly same application?
ID: 7594 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Jeff

Send message
Joined: 9 Jan 13
Posts: 1
Credit: 22,798,191
RAC: 0
Message 7596 - Posted: 9 Jan 2013, 21:35:08 UTC

I just added POEM yesterday. I got one work unit that use the GPU and everyone after that has not.

I am running Windows 8 Pro 32-bit on a 6-core AMD FX-6100 with an ATI FirePro V4900. The units were 10x faster on the GPU.
ID: 7596 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Nuadormrac

Send message
Joined: 29 Sep 09
Posts: 95
Credit: 72,775,187
RAC: 0
Message 7599 - Posted: 9 Jan 2013, 22:33:18 UTC

I'm using an app_info, and did notice the change, as the server barked about some ATI tasks being available after the old line designating no WUs available. Only thing I found odd on this however was that my hardware is nVidia based, and don't have any ATI cards at present. Course if they're the same tasks as before? wouldn't matter, and checking that might get some work. That said, if it would require an ATI card or expect one, this laptop has nVidia only...
ID: 7599 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Mad Matt

Send message
Joined: 5 Oct 09
Posts: 14
Credit: 1,525,747,428
RAC: 0
Message 7600 - Posted: 10 Jan 2013, 6:07:06 UTC

Had to run project updater for a day or so since new work seemed hard to get on one rig (AMD). Not really unusual though... ;)

I still see the apps are tagged as 1.03 on the server page. Is there any change to the app itself and would you recommend downloading new apps and updating app_infos?

Cheers,
Matt
ID: 7600 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Jason Ash

Send message
Joined: 17 Jul 10
Posts: 3
Credit: 16,206,923
RAC: 0
Message 7608 - Posted: 11 Jan 2013, 4:47:25 UTC

I've noticed the CPU units take 50 minutes each instead of about 30-35 minutes each on my Phenom II 940. Also, the GPU work units on my ATI HD5670 are taking 8 hours and 45 minutes vs. 1 hour and 20 minutes like they used to. I'm having this problem on both my Windows Vista and Ubuntu computer. Is any one else having work units take longer, especially on ATI cards? If there's more computations to make per WU, will we get correspondingly more credit?
ID: 7608 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Jochen

Send message
Joined: 27 Sep 10
Posts: 49
Credit: 37,347,110
RAC: 0
Message 7614 - Posted: 11 Jan 2013, 14:11:46 UTC

I have aborted all GPU-WUs after I had one running for 32 hours: http://boinc.fzk.de/poem/result.php?resultid=90717934

Name	poempp_gpucrystal_1357769749_44534170_0
Arbeitspaket	82969195
Erstellt	9 Jan 2013, 22:15:50 UTC
Gesendet	9 Jan 2013, 22:15:57 UTC
Empfangen	11 Jan 2013, 8:44:02 UTC
Serverstatus	Abgeschlossen
Resultat	Erfolgreich
Clientstatus	Fertig
Endstatus	0 (0x0)
Computer ID	97542
Ablaufdatum	16 Jan 2013, 22:15:57 UTC
Laufzeit	117,740.24
CPU Zeit	794.87
Pr├╝fungsstatus	G├╝ltig
Punkte	2,925.23
Anwendungsversion	POEM++ OpenCL version v1.03 (opencl_ati_100)


What's going on? First you mess up the Windows CPU-Client, now you messed up the GPU-WUs or GPU-Client?
ID: 7614 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
MaxAMD400

Send message
Joined: 4 May 08
Posts: 7
Credit: 179,013,285
RAC: 0
Message 7627 - Posted: 11 Jan 2013, 23:41:01 UTC

Hi,
for me it's 15 hours for 1 GPU WU on a nVIDIA GeForce GTX 560 Ti
http://boinc.fzk.de/poem/result.php?resultid=90821457
GPU utilization 1%, previously 50%.

regards Thorsten
ID: 7627 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
zdnko

Send message
Joined: 7 Oct 12
Posts: 5
Credit: 8,653,363
RAC: 0
Message 7636 - Posted: 12 Jan 2013, 8:20:27 UTC - in response to Message 7627.  

Same problem here: POEM++ OpenCL version 1.03 (opencl_ati_100) with 0.671 CPUs + 1.0 ATI GPU (all the previous WU worked fine with 1 CPUs + 1 ATI GPU).

I solved (+ or -) in Preferences, on multiprocessor systems, max 99% CPU (instead of 100%) so on my quad core I have only 3 core busy and GPU crunch. :)
ID: 7636 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Mad Matt

Send message
Joined: 5 Oct 09
Posts: 14
Credit: 1,525,747,428
RAC: 0
Message 7637 - Posted: 12 Jan 2013, 8:25:58 UTC

Just make sure you are idling one core per WU, that should fix the problem. With just 0.671 C BOINC could try to fill all CPU slots with CPU projects and the GPU will starve on CPU support. Using old app_infos and old core assignments, no problems did occur so far.
ID: 7637 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Jochen

Send message
Joined: 27 Sep 10
Posts: 49
Credit: 37,347,110
RAC: 0
Message 7638 - Posted: 12 Jan 2013, 8:44:47 UTC

POEM is supposed to do this automatically - and there is no other CPU-Project running on that computer.
ID: 7638 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile oldDirty
Avatar

Send message
Joined: 5 Mar 09
Posts: 8
Credit: 1,622,992
RAC: 0
Message 7661 - Posted: 13 Jan 2013, 9:22:16 UTC - in response to Message 7638.  

and there is no other CPU-Project running on that computer.

ok now i kill poem, sry dude.

ID: 7661 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Thomas Koch
Project administrator
Project developer
Project scientist

Send message
Joined: 17 Feb 12
Posts: 436
Credit: 37,847
RAC: 0
Message 7670 - Posted: 14 Jan 2013, 11:06:53 UTC

Are GPU units still not reserving a full CPU core? This should have been fixed two days ago...
ID: 7670 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Mad Matt

Send message
Joined: 5 Oct 09
Posts: 14
Credit: 1,525,747,428
RAC: 0
Message 7679 - Posted: 14 Jan 2013, 17:18:05 UTC - in response to Message 7670.  

Just got my first 1.05 and it is reserving 1C for 1 GPU. :)
ID: 7679 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Iurii Shcherbak

Send message
Joined: 24 Dec 12
Posts: 12
Credit: 2,870,538
RAC: 0
Message 7681 - Posted: 14 Jan 2013, 19:46:43 UTC - in response to Message 7608.  

See same in my ATI HD 6630M card,
actual calculation time went from 1h 26m to 2h 40m
(scheduler shows 16 hr of course :)
ID: 7681 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Jochen

Send message
Joined: 27 Sep 10
Posts: 49
Credit: 37,347,110
RAC: 0
Message 7685 - Posted: 15 Jan 2013, 16:57:02 UTC - in response to Message 7670.  

Are GPU units still not reserving a full CPU core? This should have been fixed two days ago...

I got a couple of GPU WUs today... A full core is reserved again.
ID: 7685 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Iurii Shcherbak

Send message
Joined: 24 Dec 12
Posts: 12
Credit: 2,870,538
RAC: 0
Message 7686 - Posted: 15 Jan 2013, 17:29:01 UTC - in response to Message 7681.  

Version 1.05 seems to have fixed the problem, I'm back to 1:36 per task
ID: 7686 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
yumiq

Send message
Joined: 24 Sep 12
Posts: 1
Credit: 25,576,185
RAC: 0
Message 7688 - Posted: 16 Jan 2013, 8:51:30 UTC

i'm not getting any gpu tasks for my ati 6850. i tried to reset the project under boinc, no help. running poem++ 1.06, latest boinc.
ID: 7688 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile RAMen
Avatar

Send message
Joined: 19 Oct 08
Posts: 12
Credit: 28,018,536
RAC: 0
Message 7695 - Posted: 16 Jan 2013, 20:16:38 UTC
Last modified: 16 Jan 2013, 20:27:21 UTC

all tasks failing on a 4850 with an unknown error.

Version:1.05 (opencl_ati_100)

Client state Compute error
Exit status -1073741511 (0xffffffffc0000139) Unknown error number
Computer ID 47509
ID: 7695 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Mad Matt

Send message
Joined: 5 Oct 09
Posts: 14
Credit: 1,525,747,428
RAC: 0
Message 7696 - Posted: 16 Jan 2013, 20:31:41 UTC
Last modified: 16 Jan 2013, 20:32:17 UTC

Poem@Home 16.01.2013 21:27:53 This computer has reached a limit on tasks in progress


That's new. 50 tasks isn't really much, ranging from 2.25 to 3.5 hs on some dedicated rigs and will mean a LOT of downtimes for powercrunchers in future. Not really happy here. That's almost the Milkyway range of cache and daily nursing of rigs isn't really something appealing to me. ;)
ID: 7696 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
1 · 2 · 3 · Next

Message boards : News : Scheduler Update and ATI cards


Copyright © 2017 KIT-INT