Upcoming client release

Message boards : News : Upcoming client release

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
Thomas Koch
Project administrator
Project developer
Project scientist

Send message
Joined: 17 Feb 12
Posts: 436
Credit: 37,847
RAC: 0
Message 6102 - Posted: 21 May 2012, 11:34:47 UTC
Last modified: 21 May 2012, 11:38:48 UTC

We are currently working on a new client version, which will be released soon.
Please note that the new 32bit windows client will require CPUs with SSE support.
If you are running the boinc client on a (very) old CPU, make sure if it is present.
64bit versions are not affected by these changes.

Derzeit wird an einer neuen Version für den Client gearbeitet, der demnächst erscheint.
Der neue 32bit Client für Windows wird eine CPU mit SSE Unterstützung erfordern. Falls Sie eine (sehr) alte CPU verwenden, stellen Sie vor dem Update sicher, dass dieser Befehlssatz unterstützt wird.
Die 64bit Version ist von dieser Änderung nicht betroffen.
ID: 6102 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Norman_RKN
Avatar

Send message
Joined: 17 Oct 07
Posts: 109
Credit: 20,931,870
RAC: 0
Message 6105 - Posted: 21 May 2012, 14:46:32 UTC - in response to Message 6102.  
Last modified: 21 May 2012, 14:48:05 UTC

gut so !
ich bin mir sicher,fast niemand der DC betreibt,hat einen rechner der kein SSE/2/3 unterstützt!
strom ist sa* teuer !!!
also bitte gleich nur noch optimierte apps anbieten. (evtl. mit versch. versionen (kommt auf die performance an, denn manchmal ist sse4 langsamer als sse2 - müsstet ihr testen)).

lg
norman
Rechenkraft.net e. V.
ID: 6105 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile dskagcommunity
Avatar

Send message
Joined: 26 Oct 11
Posts: 117
Credit: 368,495,687
RAC: 0
Message 6109 - Posted: 21 May 2012, 16:55:19 UTC

Ahh very cool. Should it bring some performance improvements into play?
DSKAG Austria Research Team: http://www.research.dskag.at



Crunching for my dead Dog who had "good" Braincancer..
ID: 6109 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Dirk Broer

Send message
Joined: 30 Dec 11
Posts: 6
Credit: 39,069,777
RAC: 0
Message 6111 - Posted: 21 May 2012, 17:51:10 UTC - in response to Message 6102.  
Last modified: 21 May 2012, 18:41:38 UTC

SSE? That's a P3/Athlon XP instruction set, doh!
AVX, now that would have been something...
And I will gladly believe 64-bit CPUs are not affected, given the fact that these will support at least MMX, (enhanced)3DNow!, SSE, SSE2 and AMD64 in the case of the weakest/oldest 64-bit AMD CPUs (the original 2003 Athlon 64 Clawhammer and Opteron Sledgehammer), and in the case of Intel CPUs the oldest and weakest 64-bit capable CPUs support at least MMX, SSE, SSE2, SSE3 and Intel 64 (Some models of the P4 Prescott, the Celeron D and the Xeon 'Nocona')
So, come up with an optimized 64-bit client supporting at least SSE2! (and AMD SSE3 support came quite soon in the Athlon 64 line, source:http://en.wikipedia.org/wiki/SSE3, so make that your next goal).
ID: 6111 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile [VENETO] boboviz

Send message
Joined: 30 Dec 09
Posts: 236
Credit: 48,564,069
RAC: 0
Message 6114 - Posted: 22 May 2012, 7:02:07 UTC - in response to Message 6102.  

We are currently working on a new client version, which will be released soon.Please note that the new 32bit windows client will require CPUs with SSE support.


Which version of SSE? SSE2? 3?
And, what about new gpu client (for nvidia)??
ID: 6114 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
ExtraTerrestrial Apes
Volunteer moderator
Avatar

Send message
Joined: 18 Jan 09
Posts: 454
Credit: 581,676,488
RAC: 0
Message 6122 - Posted: 23 May 2012, 15:53:57 UTC

Does this apply to the CPU or OpenCL app?

MrS
Scanning for our furry friends since Jan 2002
ID: 6122 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Thomas Koch
Project administrator
Project developer
Project scientist

Send message
Joined: 17 Feb 12
Posts: 436
Credit: 37,847
RAC: 0
Message 6132 - Posted: 24 May 2012, 11:21:16 UTC

The new requirements will apply for the complete application, CPU as well as GPU.
As it only depends on SSE1, I think barely anyone will be affected by this change.

Currently we are fixing bugs in the nvidia app, but chances are good that it will be included in this update.

An exact date for the release is not yet scheduled.
ID: 6132 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile (retired account)

Send message
Joined: 31 Dec 10
Posts: 5
Credit: 13,912,580
RAC: 0
Message 6146 - Posted: 26 May 2012, 9:43:18 UTC - in response to Message 6132.  

The new requirements will apply for the complete application, CPU as well as GPU.
As it only depends on SSE1, I think barely anyone will be affected by this change.


Right. AMD fully supports SSE1 since the AthlonXP and Intel since Pentium III and "Coppermine"-Celeron, so most users should be fine.

If any one really wants to use older CPUs, despite the waste of energy, I'd recommend to take a look at boincsimap, which works quite nicely even with a K6. However, I decommissioned my dual-Athlon XP as well as my K6-III some time ago, as they pulled to much juice out of the wall for their meager performance... :-)

Currently we are fixing bugs in the nvidia app, but chances are good that it will be included in this update.


Great, I'm looking forward to it. Do you think you can ramp up supply of GPU work units accordingly, too? Because currently I see Open-CL work unit supply is often depleted. Not today, however. ;-)

Regards
ID: 6146 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile [VENETO] boboviz

Send message
Joined: 30 Dec 09
Posts: 236
Credit: 48,564,069
RAC: 0
Message 6156 - Posted: 28 May 2012, 8:39:07 UTC
Last modified: 28 May 2012, 8:39:58 UTC

ID: 6156 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
canapa[Toscana]

Send message
Joined: 1 Jun 08
Posts: 9
Credit: 74,609,236
RAC: 0
Message 6168 - Posted: 30 May 2012, 16:57:21 UTC

News?
ID: 6168 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Thomas Koch
Project administrator
Project developer
Project scientist

Send message
Joined: 17 Feb 12
Posts: 436
Credit: 37,847
RAC: 0
Message 6192 - Posted: 1 Jun 2012, 9:53:59 UTC

There is still a bug to be fixed.
We are confident to do this during the next week.
ID: 6192 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Christopher Herr
Avatar

Send message
Joined: 13 Mar 10
Posts: 97
Credit: 1,505,265,234
RAC: 0
Message 6195 - Posted: 1 Jun 2012, 10:32:59 UTC - in response to Message 6156.  

New AMD/ATI SDK:
http://developer.amd.com/sdks/AMDAPPSDK/downloads/Pages/default.aspx

Full support to OpenCL 1.2

boboviz, as far as I know recent AMD/ATI drivers have OpenCL 1.2 on board right out of the box, at least for Windows. I do not know if you meant Linux though and I also do not know if OpenCL 1.2 is in the drivers for Linux.
If both was the case the AMD APP SDK would not be necessary, I guess...
ID: 6195 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Christopher Herr
Avatar

Send message
Joined: 13 Mar 10
Posts: 97
Credit: 1,505,265,234
RAC: 0
Message 6197 - Posted: 1 Jun 2012, 12:43:47 UTC - in response to Message 6192.  

There is still a bug to be fixed.
We are confident to do this during the next week.

Just to be absolutely sure we understand each other correctly, there will be new CPU and GPU client apps available having support for SSE, including the brand-new NVidia app, right?
Particularly interesting for people like me running so far AMD/ATI OpenCL with an app_info, as we have to manually update the app...

Thx for your time and answer!
Cheers!
ID: 6197 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile John C MacAlister

Send message
Joined: 20 Feb 11
Posts: 37
Credit: 5,252,015
RAC: 0
Message 6199 - Posted: 2 Jun 2012, 5:50:56 UTC - in response to Message 6192.  

There is still a bug to be fixed.
We are confident to do this during the next week.


good
ID: 6199 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Thomas Koch
Project administrator
Project developer
Project scientist

Send message
Joined: 17 Feb 12
Posts: 436
Credit: 37,847
RAC: 0
Message 6203 - Posted: 2 Jun 2012, 18:00:59 UTC

Just to be absolutely sure we understand each other correctly, there will be new CPU and GPU client apps available having support for SSE, including the brand-new NVidia app, right?


In fact it is not a support for, but a requirement of SSE. Everything else is just as you wrote it.
ID: 6203 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Christopher Herr
Avatar

Send message
Joined: 13 Mar 10
Posts: 97
Credit: 1,505,265,234
RAC: 0
Message 6215 - Posted: 3 Jun 2012, 17:48:18 UTC - in response to Message 6203.  

Just to be absolutely sure we understand each other correctly, there will be new CPU and GPU client apps available having support for SSE, including the brand-new NVidia app, right?


In fact it is not a support for, but a requirement of SSE. Everything else is just as you wrote it.

Okay, great! This requirement will be met by this i7 of mine.
One further question though: will the validator and the tasks stay the same, i.e. will the tasks run and validate despite having been downloaded for the current app, or do you need us to let all current tasks finish now and set BOINC to no new tasks then?
ID: 6215 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile [VENETO] boboviz

Send message
Joined: 30 Dec 09
Posts: 236
Credit: 48,564,069
RAC: 0
Message 6225 - Posted: 4 Jun 2012, 14:25:02 UTC - in response to Message 6195.  

boboviz, as far as I know recent AMD/ATI drivers have OpenCL 1.2 on board right out of the box, at least for Windows. I do not know if you meant Linux though and I also do not know if OpenCL 1.2 is in the drivers for Linux.
If both was the case the AMD APP SDK would not be necessary, I guess...


SDK needs gpu driver for gpu support, i know.
But SDK includes tools, library, documentation, examples, ecc, ecc...
So, it's very useful if you want to write an 1.2 version app.
ID: 6225 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Alex "Axel" Fox

Send message
Joined: 29 Feb 12
Posts: 26
Credit: 14,997,639
RAC: 0
Message 6226 - Posted: 5 Jun 2012, 4:45:10 UTC

Will there be any work to optimize the GPU application? I've noticed an increased volume of work being generated for OpenCL, but I still have to devote all 8 of my CPUs to complete two workunits in about 40 minutes.

Considering I'm running a 7970, this is pretty slow. Any word about this?
ID: 6226 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile [VENETO] boboviz

Send message
Joined: 30 Dec 09
Posts: 236
Credit: 48,564,069
RAC: 0
Message 6227 - Posted: 5 Jun 2012, 10:13:43 UTC - in response to Message 6226.  

Considering I'm running a 7970, this is pretty slow. Any word about this?


?? Very strange!
I'm running 5 gpu wu on 2 core of my Phenom II in 90 minutes (and i'm using hd6850)...
ID: 6227 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Thomas Koch
Project administrator
Project developer
Project scientist

Send message
Joined: 17 Feb 12
Posts: 436
Credit: 37,847
RAC: 0
Message 6228 - Posted: 6 Jun 2012, 8:09:30 UTC

One further question though: will the validator and the tasks stay the same, i.e. will the tasks run and validate despite having been downloaded for the current app, or do you need us to let all current tasks finish now and set BOINC to no new tasks then?


The tasks themselves won't change, so it should be no problem to finish downloaded tasks with the new client.
ID: 6228 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
1 · 2 · Next

Message boards : News : Upcoming client release


Copyright © 2017 KIT-INT